Step 2: Configuring and Verifying System Requirements

Because dataload.py is a Python script, you must have Python installed in order to do a data migration. More specifically, you must have Python 3.0 or later installed; previous versions (such as Python 2.7.x, which comes preinstalled on many Macintosh computers) simply won’t work. If you have Python installed but aren’t sure which version of Python is installed, you can find that out by running the following command line command:

python --version

We should point out that it’s possible to have multiple versions of Python installed, which means that, if you need Python 2.7.6 for backward compatibility reasons, you can install Python 3.0 without overwriting your previous version. (This is typically done by using the Python module pyenv.) For example, in order to write this documentation we installed Python 3.7.1 on a Macintosh computer. After the installation, we ran the command pyenv versions to verify that multiple versions of Python were installed:

system
2.7.6
* 3.7.1 (set by /Users/greg/.pyenv/version)

In the preceding output, the asterisk (*) indicates the default version of Python. You can set the default version of Python by using a command similar to this:

pyenv global 3.7.1

Because we set 3.7.1 to be our default version, that means we can run the data migration script using a command like this:

python dataload.py

If version 3.7.1 was not our default version, we’d need to use a command like this to run the script:

python3 dataload.py

Not a big deal, but good to know.

In addition to Python 3.0 or later, you’ll also need to install the following Python modules:

  • requests 2.20.1 (or later). Eases the task of making HTTP requests from a Python script. To verify that you have requests 2.20.1 or later installed, run this command:
    pip show requests
  • pyyaml 3.13 (or later). Simplifies data handling and data parsing in Python scripts. To verify that you have pyyaml 3.13 or later installed, run this command:
    pip show pyyaml
  • janrain-python-api 0.4.0 (or later). Facilitates calling the Akamai REST APIs from a Python script. To verify that you have janrain-python-api 0.4.0 or later installed, run this command:
    pip show janrain-python-api

    If you don’t have all these modules installed, the easiest way to get them installed is to download and unzip the data migration Python files from GitHub. After that, just run the following command:

    pip install -r requirements.txt

    What if you already have one or more of these modules installed? That’s fine: pip (the Python package manager) will simply skip that step and tell you that, for the specified module, the “Requirements have already been satisfied.”